Sound Shop HyperStudio

Status Displays

As you have no doubt already noticed, the Sound Shop screen display includes the display of
some important numbers concerning your recorded sound. These are as follows:

Memory Status: This indicates the total amount of system memory available for the record-
ing of a sound. In the example screen, a total of 1297664 bytes. At a given record rate, this
corresponds to a specific amount of recording time (124 seconds in this example). Changing
the slider bar in the Record Rate control will change the maximum record time displayed for
the current amount of available memory.
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This box also displays the amount of memory currenily used by the clipboard when a sound
file is in memory. Remember thal your sound sample and the clipboard share a common
amount of available memory, and that increasing the size of one decreases the amount of
available memory for the other.

Buffer Status: At startup, this indicates the amount of memory available for loading a file, or
recording a sound. It also translates this into a length in seconds for a recording or loaded
sound file. If you have already loaded a file, or made a recording, this will show the amount of
memory used for that sample. The Record time, in that case will still indicate the maximum
time available, but the Play time value will show you the actual time represented by your
recording.

The Play time shown also depends on the playback rate specified. The playback rate is con-
trolled by the Playback Rate slider control below the Buffer Status window.

If you have anything on the clipboard, the play time of the clipboard data is also indicated in
this box.
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Editor Status: This window indicates the magnitude of the sound wave at the point currently
selected. This is useful for cutting, copying and pasting sound segments from one point in the

file to another. Try the select process now by positioning the mouse in the sound wave display
window. Now hold down the mouse button while you drag the mouse to one side or the other.
Note that the area selected is highlighted, and that the Editor Status box shows the magnitude

of the sound wave at the current selection point.

Record Threshold: When you start the recording process, you may want the system to wait
until rhere_:s an actual sound to start recording. Since there is always some degree of back-
ground noise in the system, the threshold setting allows you to specify what initial value of an
incoming sound should trigger the start of the recording process. When a non-zero Threshold
value is used, the screen border will turn green while Sound Shop waits for a sufficiently loud
sound 1o start recording. When the recording process starts, the screen border will tum red.

Play Volume: This lets you set the playback volume of a sound sample. Values that are too
large may "overdrive" your speaker system, so iry to use a value that gives the best sound. The
exact value may depend on the speaker and/or amplifier system you are using,

Echo Delay: This control is used for creating special "echo” effects with your sound sample.
See the description earlier for details. % i

Repeat Count: This value determines how many repeated plays of the selected sound sample
w!l.'l be played. You can use the repeat count to create an apparently longer sound effect,
without using the large amount of memory that would otherwise be required.
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Sight 'n Sound

Sight 'n Sound is a fun utility provided so that you can change the startup process of your
Apple TIGS to put a picture on the screen while the computer is starting up, and/or have a
sound you have recorded play as well.

In addition, for those programs that use the standard Apple "beep”, such as an Applesoft
BASIC program, or others, you can replace the "beep” sound with your own sound, such as
"oops!”, the sound of breaking glass, a pleasant "try again", or whatever you like.

Sight 'n Sound is easy to use. Just click on the Sight 'n Sound icon in the HyperStudio Home
Card, or launch it from the Finder, ProSel, the DeskTop, or any other program launcher.

When you use Sight 'n Sound, the title screen will appear. Let's take a look at each of the
options:

Startup picture: When you click on this, you will be presented with the standard file selec-
tion interface. Use the disk and open buttons as necessary to find the picture you want to use as
a startup picture. To try it now, you can use any of the graphics on the HyperStudio.Art disk.

Once you have selected your picture, another dialog box will appear with a miniature image of
the picture, and ask you if this is really the picture you want to use. If it's not, clicking on "No,
pick another” will take you back to the file selection interface. Assuming you've found the
picture you want, clicking on "Yes, install" takes you to the next step.

Now all you need to do is to tell Sight 'n Sound on which disk you want put the picture. You
can use your HyperStudio disk (a backup copy of the disk, that is), as a test disk if you wish.
Ordinarily, you'll want to insert a normal GS/OS disk in the drive. You can use Next Device to
bring up the name of each disk drive you have connected, or the Re-Check Device to re-
examine a disk drive afier you've put in a new disk.

When the name of the desired target disk is shown on the screen, click on the Install button to
complete the installation. If a startup picture already exists on that disk, you'll have the oppor-
tunity to cancel the operation, or continue anyway.

Note: There are actually two Sight 'n Sound programs on the HS.Sounds disk. SNS.320 adds
320-mode Super Hi-Res graphics 10 a disk; SN5.640 does the same for 640 mode grahics. The
graphics from the HS.An disk are all 640 mode graphics. Screens from PaintWorks Plus are
320 mode.

Startup Sound: This is similar 1o the startup picture function, except that it will put a Sound
Shop-recorded sound on your disk that will be played when the computer starts up.
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Selecting a sound is done Jnsl like any other file, except that after you have selected it, you'll
anet.peoppnrtumlywplny it 10 make sure you've got the sound you want. If it is, clicking on
Yes, ms!.n]l"mkcsymmﬂmmcdiskselacﬁondialngmmmwasusedwheni:mﬂinga

starlup picture,

Note: It‘yuursoundsmnpletakcslmgermplaymmme:imeinakcsymrctiskmmnup.ﬂae
end of the sample will be stopped prematurely as your actual startup application is loaded. The
um::.avm!able for a startup sound varies according to the type of disk drive you have, and what
s:;f:tfm;amlsun your disk, so some customizing of the startup sound may be desired for the best
effect.

Sgslem Beep: This is for replacing the usual "beep” in Applesoft BASIC and other programs
with a recorded sound of your choice. The process is identical to adding a Startup Sound, but
your custom sound will only be heard when the Apple IIGS system beep is used.

Removing Startup Files: Any or all of the files just added can be removed by simply using
the Remove buttons on the right of the Sight 'n Sound function box. In each case, all that is
displayed is a dialog box for selecting a disk. For each device, Sight 'n Sound will tell you
whether there is currently a startup file on that disk or not.

File Usage: Sight 'n Sound adds the following files in the System Setup folder of the target
ﬂ The System.Setup folder is located in the System folder present on any GSOS startup

For a Startup picture:

SNS.5P This is the program that actually loads the startup picture.
SNS.SP.PIC The picture to be loaded. e
For a Startup sound:
5NS.S5 This is the program that actually loads the startup sound.
SNS.SP.SND The sound to be loaded. Y
For a system beep:
SNS.SB This is the program that actually loads the system beep.
SNS.SB.SND The sound to be loaded.

The files SNS.SP, SNS.SS, and SND.SB must be on the disk in the same directory as the Sight
'n_Snund‘uultty for an installation to work properly. If the files are not found, then a message
will be displayed when the installation is attempted. The Sight 'n Sound utility does not have
10 be on your own disk for the startup functions to work.
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or ProSel, you can also get a longer display time of the picture, and a longer play time by the
sound, if you move the files SNS.SP and SNS.SS to the top of the Sysiem.Setup folder.
SNS.SP cannot be moved to a position before CDEV.Init in the System.Setup folder.

Sound Browser

The Sound Browser is a utility for quickly looking (listening?) through a number of sound files
on a disk. It is very simple to use, and just presents the usual file selection interface to choose

the files you're interested in. Only Sound Shop-compatible files are displayed. After a md is
loaded, it is immediately played. After playing, you can then choose another sound to listen to.

Sim:csunusou:ﬂsnmplcsmnbcraﬂ:erlmg.mu-eisalsuas]jdu;nnuql:hnﬂmymﬂadjusi
memomtofe-nchsuundﬁlnwbemadinmdphyed.mm_umbqwge
through a large number of samples when you're looking for something in particular.

When you're done browsing, just click on Cancel to return to the HyperStudio Home Card,
Finder, or any other program selector.

e i pr—
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Appendix A: Stack Ideas

One of the traps in looking at example stacks done with HyperStudio is the temptation to
immediately classify, and thereby limit, your impression of possible applications in terms of
what you have already seen. HyperStudio can be used to create a fantastically wide variety of
software. Here are just a few more ideas on possible stacks that anyone could create:

» Child's ABC Book. Imagine a stack created of screens with the letters of the alphabet, and
objects like an Apple, Bear, Clown, etc. When the child clicks on a screen image, they hear
the phrase "A is for Apple”, eic. A variation is to have the stack immediately play a phrase,
and then have the child click on the image needed to maich the verbal prompt. The stack
would then respond with a happy face, or try again voice before going on 1o the next card.

* Interactive Adventure Story. In this setup, a card could have, for example, a castle with
two doors. Depending on which door (invisible button) the user clicks on, the story would
branch to alternative story plots. You could create a wide variety of plot variations within a
"story-stack”.

* Repair Guide. This stack starts with an picture of a camera, bicycle, copier, faucet, motor-
cycle, carburetor, or anything else that you have ever seen a repair guide on. From there,
clicking on different parts of the picture leads you through disassembling, repairing, and re-
assembling the device.

* Office Building/Personnel Guide. This stack would offer a directory to different offices
and personnel in a business. Click on different departments to get a map of how to get to a
given office. See an organizational chart of personnel. By clicking on a position in the chart,
you get a picture of the person, an introduction in their own voice, information on their duties,
services provided, etc.

* Interactive Tests. For school or business, you can use HyperStudio's ability to use its
buttons as "answers" in a test to creale interactive quizzes, tests, elc.  When a testing stack is
completed, HyperStudio writes a text file out o disk that has a list of the "answers" (buttons)
chosen on each card, the stack name, student name and date. Other programs can then access
this information as needed.

* Introduction to Classical Music. This stack plays passages of classical music, and asks the
user 1o identify the composer and/or name,

* Family Tree. Geneology is an area that is very difficult to implement on a classic-style
database. By contrast, HyperStudio lets you create a card for each family member, putting a
picture of the person, details of their life, even a voice sample, on each card, The cards are
then linked according to relationships as needed. Cards can also branch to general information
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such as the origin of the family name, information on the country of origin, interesting stories
or incidents, elc.

« United States or World Database: Information on all 50 US States or World. Additional
Quiz format that has you identify a state by clicking on the correct spot on a map in response
to questions, facts & trivia.

= Animals of Africa: Learn about the wildlife of Africa. Click on a country in a map of the
continent, and then go on a safari, exploring the animal life of the region. Hear lions roar, the
rumble of a thunderstorm on the savannah, even the rushing waters of Victoria Falls!

= Knowing the Masters - Art: Leamn to identify classical works of art by matching a picture
with the title of the work and the artist.

* Dynamic Flow Chart Demo: Here's a novel idea: Make each card in a stack a step in a
classic program flowchart. As the user clicks on Yes/No choices, they move through the
"program” (the stack).

These are just a few of the possible applications of HyperStudio. There are many, many more.
In fact, a good source of ideas is to just walk into any bookstore, and look at the variety of
subjects and presentations on the shelves. A large number of the things you currently see in
printed form can be done in hypermedia in a totally new and refreshing way.

HyperStudio Catalog

Roger Wagner Publishing, Inc. is putting together a catalog of public domain and commer-
cially sold HyperSwdio stacks. We also hope to include other items that would be of use to
HyperStudio owners, such as video digitizers, scanners, sound effecis tapes, records, CDs,
software utilities, and other products. This catalog will be sent free to all registered
HyperSiudio owners.

Mailing in your registration card is the only way we have of knowing you are a HyperStudio
user to send you the catalog, and notices of future updates and improvements to the software.
If you haven't already done so, please mail the registration card today.

If you have created stacks that you think would be of interest to others, we would also like to
hear from you. Write or call Roger Wagner Publishing, Inc. at the address and phone number
listed at the front of this manual.
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Appendix B: More On Animation

The dt._:scriph:cq in the manual of how animation works is accurate, but it's easy 1o overlook
how simple it is to create an effective animation in a stack you are creating. The following
mini-tutorial is provided w help you experiment with creating animations in your own stacks.

Blinking Objects (Names, arrows, etc.):

The first example will be of how to create a blinking item on the screen when a button is
press;._d* This could be a name, an arrow pointing to a location, or any other alternating
graphic,

To try this out, choose New Stack from the File menu, and then use the Add Clip-art function
(also in the File menu) to bring up the file Output, located on the HS.Art disk. In the upper-left
corner of the screen for the Output file is a picture of a printer. Use the square selector tool to
draw a rectangle around the printer image, and click on "Ok" at the top of the screen. The
image of the printer will appear on the screen. Use the mouse to position the image in the
upper-left part of the screen, and click outside the image to drop it in place,

We'll suppose that this is the first card of a stack about computer terms. Suppose you wanted
the user 1o click on the printer, and then hear the spoken word "printer”, and also see the word
flash momentarily on the screen.

To do this, we'll attach a sound and an animation to an invisible button over the printer image.
The animation will consist of two frames, one each with anu without the word "printer”, We'll
then repeat this animation sequence three times.

Before the animation can be connected to a button, however, the sequence must first be cre-
ated. An animation sequence consists of a series of graphics screens, with some difference
between each successive frame. Viewing the frames rapidly creates the animation effect. For
a p#ﬁng object, the sequence is very simple: One frame with the object, a second frame
without.

To create the first frame, select the "T" icon in the Tools menu (the paint text tool). Click the
mouse on the screen somewhat below the printer image, and type the word "Printer”, This will
be our first frame of the animation. Go to the File menu, choose Save Screen, and save the
screen under the name Printer.1,

Now, use the eraser tool 1o erase the word "Printer”. The screen with the word gone will be the
second frame of our animation. Go back to the File menu, choose Save Screen, and save the
screen under the name Printer.2. Now it's time to create the button that will trigger the
animation,
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Go to the Objects menu, and choose Add a Button. Choose the invisible button style, and click
"Ok". It is not necessary to enter a name for an invisible button. Afier an optional instruc-
tional dialog box appears (if this is the first button you've added after starting up HyperStudio),
the rectangle for an invisible button will appear on the screen. Use the mouse to drag the
rectangle over the image of the printer, and to resize it to something that completely covers the
printer. It is all right if the rectangle is larger than the printer image.

When the invisible button rectangle is positioned, click outside the rectangle to drop it in
position, Now click on Play a Sound, and choose Record Now. When the tape recorder
appears, click on the Record button, and say "This is a printer”, then press a key to stop the
recording. Click on the Play button to verify you've got a good recording. You can also adjust
the volume here to a comfortable level. When the sound is set up correctly, click on "Done”.

Note: If you hit a key to stop the recording, and do it loudly, the "click” of the keyboard will
be included at the end of your recording. If you hear a click at the end of a recorded sound, iry
recording again, and press a key to stop the recording.

When the Button Actions menu reappears, click on Activate Animation. When the list of files
appears, choose Printer.1 to specify this animation sequence. A window will appear, probably
with the image of the printer in it. Use the mouse 0 drag the hand cursor to move the printer
image, and bring the word "Printer” into view. Move the word "Printer” into the upper-left
corner of the animation rectangle. Now resize the rectangle to a smaller size, to neatly frame
the word "Printer”, but try not to make the rectangle too small. You just want to create an
image you can work with.

MNow use the mouse to drag the frame of the animation rectangle, and place it under the image
of the printer. Click outside the animation rectangle to drop it in position. A message will
appear telling you HyperStudio is generating the animation, and then the Button Actions dialog
will appear again. Set a Rate of 45, and a Repeat Count of 3, then click on Done.

Now let's try it out! Click on the image of the printer. You should hear the phrase “This is a
printer”, and see the word "Printer” blink three times.

It's that easy! Blinking objects are the easiest to create, because you only need two frames. If
you want the object to be left on the screen when the animation is done, make sure the last
frame of your animation has the object visible. In that case, you would make the first frame
the "empty"” picture (no word "Printer"), and the second frame would have the word visible.
Then, when you create the animation, click on Printer.2. This will bring up the second frame
in the animation window, so you can still place the word "Printer”. However, this time, the
word "Printer” will be visible when the animation ends, and thus left on the screen for the user.

This technique could be used for a blinking arrow, or wamning-light effect.
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Important Points:

1) Wha'tevm' filename you click on when selecting an animation is the one that will be loaded.
Dc-n'lcluckonaﬁanmwhm:menhjmtisnmvisible,becaumyouwm'lbcableMphceh
where you want it (since it won't be there!).

2) HyperSwmdio always uses the entire available sequence from Filename.1 to Filename.999,
regardless of which file you click on.

3) The last frame of an animation is always left on the screen. If you want the object to stay
on the screen, make sure it's visible in the last frame, If you want the object to disappear, make
sure it's erased from your last frame.

4) Animation files do not have to be continuously numbered, or even begin with any particular
number. You could have the files Printer.20, Printer.25, and Printer.99, for example.

Moving Objects:

In this next example, let's create a simple sequence of a plane flying across the screen, and
introduce the idea of a stack-based "work file" for an animation.

Choose New Stack from the File menu. Go to the File menu again, and choose Add Clip-Art.
From the HS.Art disk, open the file Output. Near the right edge of the screen, you'll see an
image of a jet airplane. Move the slider bar at the bottom of the window until the airplane is
wotally visible, and then use the mouse to draw a rectangle around the airplane. Click on Ok
when you've selected the correct area. Now position the airplane at the left side of the screen,
and click outside to drop it. If you've accidentally got any extra graphic bits on the screen, you
can use the eraser tool to erase them.

The idea in creating this animation will be to create a series of cards in a stack that has the
airplane moving to the left a certain amount in each successive card. This stack will only be
used to create and edit the animation, and not for any other purpose. As such, it becomes an
animation "work file",

Go to the Apple menu, select Preferences, and make sure that Erase background on new card is
not checked, and that Show card number in menu bar is checked. We will let HyperStudio

automatically duplicate the background for each new card in the animation. Click on OK in
the Preferences dialog box.

Pull down the Tools menu, and choose the selector tool (the square dotted line icon). This is in
preparation for selecting graphics in a moment. Press Apple-N (for New Card). The number at
the top of the screen will change to "2". You are now on the second card in this stack. Use the
mouse 10 draw a rectangle around the airplane, and drag the image about 1" to the left. Press
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Apple-N again 1o create the third card. Again, select the airplane image, and drag another 1" to
the left. Repeat this process two more times until you have six cards, each with the airplane in
a different position.

You now have a stack of six cards with the frames for an animation. You can hold down the
Apple-> key to move through the cards in the stack and get an idea of how your animation will
look. Now, let's save the frames as graphic screens for use by HyperStudio's animation
feature.

Go to the Move menu, and select First Card. Now go to the File menu, and choose Save
Screen. Make sure you have a disk with at least 80K free on it. The default name in the Save
Screen dialog box should be New.Pic.01. Normally, you would replace this with a name of
your own, but for the moment, this will work perfectly for saving a series of numbered graphic
screens. Press Return to accept this file name. When the save is complete and the screen
remums o card #1, press Apple-> (Next Card), and then choose Save Screen again. This time,
the default name will be New.Pic.02. Press Retum to accept. Again, go o the next card and
save that screen, and repeat until all six cards have been saved Lo disk. (If the Save Screen
doesn't begin with New.Pic.01, because you've already saved a screen earlier, don't worry.

You just want to save a numbered series of screens - the actual starting number doesn't matter.)

Now is a good time to save the stack itself. Choose Save Stack from the File menu, and save
the stack under the name Plane.Work. By keeping the file, you can go back later and make
changes to the animation sequence, without having 10 recreate the graphics.

Now, let's try out the animation. Choose New Stack from the File menu. Then, choose Add a
Button from the Objects menu, create a visible button called Test, and position it near the
bottom of the screen. Check "Activate animation...”, and when the file selection dialog ap-
pears, select New.Pic.0l. A white rectangle will appear in the middle of the screen. Use the
mouse (o drag the rectangle to the left side of the screen, then grab the handle on the left edge
of the rectangle, and resize the rectangle to be as roughly as wide as the screen. You probably
can't see the airplane, because it is out of view in the window. Move the mouse to inside the
rectangle, hold down the mouse button, and drag the mouse up until the plane is in view. The
size of the rectangle represents the animation area, and needs to have the full left-to-right area
available for the complete motion of the plane. Click outside the rectangle, and a dialog box
will appear telling you HyperStudio is creating the animation.

When the button Actions dialog box reappears, enter a Rate of 10, and a Repeat count of 2,
then click on Done. Now, test the animation by clicking on the Test bution. The plane should
fly two times from right to left across the screen. If you didn't want the plane image 1o be left
on the screen at the end of the animation, you would leave a blank frame at the end of the
animation sequence, as card #7 in the Plane.Work file, and saved as New.Pic.07 on disk.
Remember, it is not necessary that the picture files you save begin with "1", or that they be
continnously numbered. You can always use any name you wish for the animation files, as
long as they end in some number, and all share the same name as the beginning of the file-
name.
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Appendix C: Improving Sound Quality

The following information is provided to help you get the best resulis possible when recording
and playing back sounds using the Sound Shop and HyperStdio software.

All of the smmds you hear on the HS.Demo and HS.Sounds disks were recorded using the
HyperStudio digitizer. The voice in Saturday and Spanish were recorded with the HyperStudio
microphone. All others were recorded from casseltes, using an inexpensive walkman-style
cassette player.

You should be aware that there is some variation in individual Apple IIGS computers, so your
computer may be slightly quieter or noisier when recording sounds than others. However, with
a little understanding of the things that effect the overall quality of a recorded sound, you
should be able o get the best possible performance from your machine,

Avoiding Electrical Interference

The biggest source of problems in recording sounds is the electrical “noise” that is inherent in
the computer. This is not noise that you can normally hear, but when the digitizer records a
sound by converting it inio electrical signals, the electrical activity in the computer and the
surrounding environment can be picked up, and mixed into what you are trying to record.

The HyperSmdio digitizer minimizes this problem by nor plugging into one of the slots in the
computer. Being physically connected to a slot is the surest way to transmit the electrical noise
from the computer into a digitizing card.

If you are having problems with excessive noise in your recordings, consider each of the
following, and see if any of these apply to your situation.

Note: “Excessive noise” can be detected by doing a “smothered mike” test. This consists of
holding your hand over the microphone, while you record about 5 seconds of silence in Sound
Shop. When the sound wave is drawn, examine the display. If the “bumps” in the display are
more l.hnn +/- 3 units in value (click on a given point and lock at the Level value in the right-
hand window), or they appear in large quantity at a regular frequency, then you may have noise
in the system that can be eliminated. If you are concerned about excessive noise in your
system, and are writing us about the problem, sending a disk with sample recordings will help
us a great deal. Record one sample with the smothered mike test, and one sample of your
voice.

Do keep in mind that even at best, there will always be a small amount of background noise in
the quiet passages of a recording. This is normal for the system. Even a tape player, when the
volume is turned up, has a background hiss.
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Monitor - The Apple [IGS nmnitnrisnwongsnmpfeiac!ﬁcalmise. ‘.[f:hethemir:m
phone is closer than about 12" while recording, you will get interference from t!'m monitor.
Avoid this by just being careful not to lean in towards the monitor while recording, or draping
the microphone wire over the top of your monitor.

Fluorescent Desk Lamps - Flourescent desk lamps are also a strong source. Don’t record
with the microphone or its cable directly beneath (closer than 127) a disk lamp.

OtherSoundCuds-TthywShﬂiodigiﬁmisquimmmimmbethd:mmitplug
into the internal slots in the computer. Howevcnifyoumusingthe“piggy-bmk option to
connect another sound card to the HyperStudio digitizer, you probably will get more noise than
if no card was connected. This is because the electrical noise can now flow from the slot
connector, into the other card, and then into the HyperStudio digiﬁw._Unfmmmmly.ﬂm
isn't any way around this problem other than not connecting the offending sound card to the
HyperSmdio digitizer.

The other altemnative is that, if you do have another soundcard.yoapmbablycanusa'g!m
record sounds in both Sound Shop and HyperStudio, without “equiring the H;E-pg'Smdm
digitizer to be present at all. Obviously, the sound input quality will then be limited by the
quality of your own digitizer card.

Fans - The Apple 1IGS internal fan from Apple Computer should not cause a problem when
attached to the HyperStudio digitizer. However, there are some inexpensive third-party
models that can cause problems. External fan units, such as the Kensington System Saver GS,
or the MDIdeas/Applied Engineering Conserver should not cause any problems, since their fan
power supply is separate from the fan power line inside the Apple IIGS.

If you do have a problem with a third-party internal fan, mgmis no easy solution, other than to
replace the fan with another unit. However, if you are feeling a little adventurous, or want an
absolutely perfect power source for the HyperStudio digitizer card, you can buy a 9-volt
battery clip from Radio Shack, or any other electronics parts suppty house, and use a 9_m_lt
battery to power the digitizer card. You can literally push the wires from the battery clip into
the 2-wire plug on the digitizer card that would otherwise plug into the fan plug inside the
computer. Be sure, however, that you get the polarity right. The red (positive) wire from the
battery clip should match the red wire in the digitizer card plug.

Placement of the Ribbon Cable - Although usually a minor factor, you can try running the
ribbon cable from the HyperStudio digitizer over the top of any peripheral cards in the com-
puter, rather than under them. This will keep the ribbon cable away from the motherboard
itself, which is a potential source of electrical noise. However, be aware that it is possible that
some particular card will have a component mounted near the top of the card that will be a
stronger source of interference than the computer itself. Placement of the ribbon cable is
simply one more option for you to experiment with.
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Other cables - In general, you should try to keep the microphone from being entangled in
other cables at the back of your computer, such as disk drive cables, printer cables, etc. Try to

keep the microphone cable running in a relatively direct path from the back of the computer to
your work area.

Power Supply - Although rare, the internal power supply can also be a source of some noise.
After you've tried the other options, you can try moving the digitizer card away from the
power supply, into one of the other cutouts, if you don’t have t0o many other cards in other
slots,

Improving the Input Quality

To get the best sound possible in HyperStudio, you can also take certain steps to improve the
overall quality of the sound input to the HyperStudio digitizer card.

Microphone Technique - When speaking into the microphone, be sure to hold the micro-
phone right up to your mouth, and speak clearly and firmly. It is not at all necessary to shout,
but you shouldn’t be timid, either. Sound Shop is the best place to practice with recording
sounds, since you can see an actual display of the sounds you are recording. You want the
waveform displayed in Sound Shop to approach the top and bottom of the window in places,
without actually going out of range. A recording that does not produce a good waveform will
sound noisier than one done with sufficient volume. Also, remember that if the microphone is
12" away from you when you speak, this will be 100 far for HyperStudio or Sound Shop to pick
up any kind of a strong sound input at all.

Other Microphones - Although the microphone in the HyperStudio package is quite sufficient
for casual use, other microphones may give better results. The simplest improvement is to use
a condenser microphone. These cost approximately $15 from places like Radio Shack. How-
ever, you should also realize the improvement is unlikely to be overwhelming. In very unsci-
entific terms, we rate better microphones as giving about a 10-20% improvement in the overall
quality of recordings.

Signal-to-Noise Ratio - This is a term that refers to how strong your recorded sound is com-
pared to the always-present electrical noise in any recording system. If you are recording with
& quiet voice or input source and/or playing back at a large (12-15) playback volume level,
then background noise will be most noticable, and very difficult to eliminate, If you can get a
good strong waveform in Sound Shop when you record (90% deflection in the window at the
high spots), then your input will overshadow any background noise. In addition, if yOu can use
an external speaker with a volume control that will let you play back sounds with a playback
volume of 6-8, then the background noise will be minimal compared to your recording. Re-
member, almost every recording will have quiet gaps between words, musical passages, or
other sounds in the recording, and it is in these spots that the background noise will be most
noticeable. If the playback volume is at the high end (12-15), then this background noise is
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amplified as well. Again, try to make strong recordings, and ideally, use a medium playback
volume level.

Tape Player vs. Microphone - You may get better results for some recordings by recording
first into a standard tape player, and then recording in Sound Shop from the tape player. This
is because you can control the volume in the output from the tape player, and and the recording
situation is a “closed system”, i.e., no outside noise.

It it certainly true that for digitizing sound effects, music, etc., you should definitely record
direct from the tape player, and not try to hold the microphone next to a speaker while the tape
plays.

Battery Tape Players - Although you might think an expensive tape deck would be the best
source when recording music, sound effects, etc., we recommend you use a battery-powered
tape player. 110v units often transmit electrical noise to the digitizer card. A battery-powered
unit is more likely to give you a good clean input sound.

Improving the Output Quality

The sound output quality of the Apple IIGS is almost entirely a function of how good the
speaker attached to it is. You should, of course, avoid entangling the cable going to the
optional HyperStudio speaker with disk drive cables, or other wires that are a source of inter-
ference.

The HyperStudio speaker will give a substantial improvement over the GS built-in speaker.
Powered speakers, such as the Yamaha DM-01 model (our favorite), will give the best per-
formance. You cannot hook up standard sterco speakers to the computer, since an amplifier of
some sort is required. You may also wish 1o look into other suppliers of amplified speakers,
such as Radio Shack.

Sound Shop and HyperStudio do not currently support stereo sound in either recording or
playback, although this may change in future versions of the software. However, you can use
stereo output cards as the sound output channel in HyperStudio without any particular steps
being necessary.

What about other sound file formats?

When the HyperStudio project was started, we looked around for a standard sound file format
that would accomodate all the requiremenis for HyperStudio. The primary requirement was
that the user be able to load a sound file stored on disk, and play it immediately without
resetting any parameters. This requires that values for volume, playback rate, echo delay,
repeat count, etc. all be stored in the sound file on disk.
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Unfortunately, no file standard currently exists (other than the HyperStudio/Sound Shop file
format) that accomodates all these requirements, and also provides for compressed sound files.

For that reason, Sound Shop and HyperStudio use a specific type of sound file, registered as an
official file type with Apple Computer, that contains all the necessary information. HyperStu-
dio can only directly import this type of sound file. If you have sound files from other sources,
you can use these sounds by first loading them into Sound Shop, and then resaving them in the
HyperStudio/Sound Shop file type.

In Sound Shop, you should be able to load sound files recorded with MDIdeas, FutureSound,
Sonic Blaster, Sound Studio and other programs. Sound Shop does not currently load com-
pressed sound files, although this is also expected to be handled in a future version.

If you have access to a modem service such as GENIE, CompuServe, or America Online, you
can also download digitized sounds for use in Sound Shop. Macintosh sound files will also
work in most cases when loaded into Sound Shop. If you have a Macintosh computer, and the
utility AFE (Apple File Exchange), uncompressed B-bit sounds recorded in MacRecorder, or

other digitizers, can also be converied to a ProDOS disk with the AFE utility, and then loaded
into Sound Shop.

Once loadnd you may have to set the volume, playback rate, etc. to get the sound just the way
you want it. When saved and reloaded into Sound Shop or HyperStudio, the sound will then
play perfectly every time.

Sound Shop and HyperStudio do not currently support MIDI music files, or other synthesized
note sequences, such as those produced by Music Studio, Music Construction Set, Diversi-
Tune, or other programs that do not use digitized sounds. This may also be addressed to some
degree in future versions of HyperStudio.
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Appendix D: Hard Disk Installation

Installing HyperStudio on a hard disk is very easy. The most direct way is to create a folder on
your hard disk named HyperStudio, and copy all the files from the disks HS.Demo,
HS.Sounds, and HS.Art to the folder. From the HyperStudio disk, copy only the files Hyper-
Studio, HS.TD, and Home.5Stack.

Your hard disk must be set up to use GSOS 5.0.2 or later. If you'll be using the Video Overlay
Card, you should also have installed Tool033 (Tools folder) and Apple IIVOC.Init
(System.Setup folder).

Once in the HyperStudio folder, HyperStudio can be launched by double-clicking on either
HyperStudio (from the Finder). Sound Shop can be launched by double-clicking on the Sound
Shop icon. If you have an Icon Editor, you can change the application pathname for the stack,
sound file, and other icons so that you can also launch HyperStudio or Sound shop by double-
clicking on the stack or sound file icons.

When HyperStudio brings up the Home Card, clicking on any of the icons should run all of the
demonstration stacks normally. Adding clip-art and sound files should also immediately
display the appropriate files as copied from the HS.Art and HS.Sounds disks.

Using Subdirectories: When using HyperStudio on a hard disk, you may want to organize the
files into subdirectories, such as creating the folders HS.Art, HS.Sounds, and perhaps even
individual folders for groups of stacks. This is fine, but you should realize the basic operating
"rules” with multiple direciories.

Last-used directories: When adding clip-art, sound files, loading stacks, etc. HyperStudio
remembers the last-used directory for various kinds of data. This makes it easy to go back to
the last directory you loaded something from. However, you should also remember that if you
put artwork, sounds, etc. in other directories, the first time you go to add clip-art, you will have
to use the Standard File interface 10 open the necessary folder. If you have a large number of
HyperStudio-related files, you may find that organizing subdirectories is both useful and
necessary.

Page B6




Manual Addendum & Index

The following pages contain information about features added to HyperStudio after the manual
was printed, additional tips on using the software, and an index for the HyperStudio manual.

Hard Disk Installation

The Home Stack now includes an icon (via the Applications button) called HyperStudio
Installer. This utility will automatically move all the appropriate files from the HyperSwdio
disks Hgoyuu’harddisk. Within the HyperStudio folder, it will also create the folders HS.An
and HS.Sounds.

When installing HyperStudio on a hard disk, a few changes will have Lo be made (0 the
Home.Stack for a few of the stack icons to work without prompting for the 3.5" disks. The
modification is required for those stacks located in subdirectories.

The stacks Jukebox, Art Library, Xcmd Info, Find Demo, and Video Overlay will be located in
the subdirectories Hs.Sounds, HS.Art, Xcmds, Xcmds/Find, and Xcmds/Video, respectively.

When you click on the icons for these stacks, HyperStudio will try to locate these stacks on the
original 3.5" disks. If you don't want 1o have o put the required disk in your drive when trying
these demos, delete the invisible buttons in the Home.Stack, and create neéw buttons that
connect to the comresponding stacks in their new location on your hard disk.

There is also a connection to another stack in the ArtLibrary stack. This invisible button is
over the lamp on the second card, and normally connects 1o the stack Test.320.Stack in the
Test.320 folder on the HS,Art disk. Delete the invisible button over the lamp, and create a new
one that connects 1o the Test.320.51ack in its location on your hard disk, which should be a
folder named Test.320 in the HS.Ant folder.

Here's a list of the stacks in the Home Card that you'll have to create new buttons for:

Stack New Location
Art Library HyperStudio/HS. Art/Art Library
Jukebox HyperSwudio/HS.Sounds/Tukebox

Find Demo HyperStudio/Xcmds/Find/Find. Demo
Xcemd Demo  HyperStudio/Xcmds/Exerciser/Xcmd.Demo.Stack
Video Overlay  HyperStudio/Xcmds/Video/VOC Demo




Remember, 10 delete an existing button, just choose the button tool (the "B" in an oval) from
the Tools menu, click on the button 1o be deleted, and then choose Clear Button from the Edit
menu (or just press the Delete key).

Tip: Whenever you get a dialog box asking to locate a particular file for a button you have
clicked on, remember 10 look at the top of the dialog box to see just what file HyperStudio was
looking for. This will help you create new buttons 1o go 1o the desired file,

Unidisk Drives (White): Important: the following information applies only to the older
Unidisk drives, which are white in color. There is no problem with the newer Apple 3.5 drives,
which are platinum (grey).

The Unidisk drives have a problem in that they don't "know” when a disk has been removed.
This leads to the following problem in HyperStudio, or any other deskiop style program on the
Apple IIGS:

You are working in HyperStudio, and for some reason, it prompts you o insert a needed 3,5"
disk. You already have another disk in the drive, so you remove it, insert the comrect disk, and
press Return. HyperStudio appears to not recognize the new disk, and asks you o insert it
again.

The problem is that, combined with the caching featre of GSOS, the computer still thinks the
original disk is in the 3.5" drive. The only solution here is to remove the original disk when
prompied, and then press Return before inserting the new disk. This forces GSOS 1o see that
the drive is now empty. Then insert the correct disk, and press Return again when it asks you a
second time for the needed disk.

A variation on this problem is when adding clip-art, loading or saving stacks, or any other
function that uses the Standard File Interface dialog box that is used in HyperStudio to select
file. If the disk you want to access is not in the drive when the dialog box comes up, replacing
the disk with the correct one and choosing the "Disk" button in the dialog box (or pressing the
TAB key) will not show the contents of the new disk. This is caused by the same problem:
GSOS doesn't know a new disk is in the drive. The only solution is to remove the first disk,
click on the "Disk" button so GSOS sees the disk is gone, then insert the new disk, and click
on "Disk" again so it recognizes the new disk. If you have other disk volumes online, such as a
hard disk, you may have to page through them each time to get back to your 3.5" drive.

New Feature Summary for
HyperStudio 2.1

This new version of HyperStudio has a number of improvements (o the software to make it an
even more powerful tool for you, while still keeping the software as easy 10 use as possible.
The following pages describe the specific changes to the software.

New Paint Tools:

« Stretch/shrink selected graphic areas (lasso & square selections). Afier selecting a

graphic item with the lasso or square selector tool (the dotted square in the Tools menu), place
the tip of the arrow cursor on the lower-right comer of the square (or an approximation of this
position if you're using the lasso). If you then hold down the Apple key while you drag the
mouse either up and to the left, or down and to the right, you'll see the graphic area re-sized as
you move the mouse. Because the original graphic is made up of individual points (pixels), the
resized graphic may show some distortion, but you should still find this a useful function.

« Easy straight lines ("constrained motion™). If you hold down the shift key before moving
the cursor, you'll notice that many paint tools (paint brush, eraser, pencil, line tool, etc.) will
auiomatically draw a perfectly horizontal or vertical line once the mouse starts moving. This
can be helpful when trying to erase a straight edge, as well. If you hold down the shift key

while using the rectangle or oval tool, you'll get a perfect square or circle.

+ Flip horizontal'vertical (Edit menu). When a graphic area is selected with the rectangle

or lasso, the functions "Flip horizontal” and "Flip vertical” in the Edit menu will be available.
These are useful when creating symmetric comers of your screen. For example, on the HS.Ant
disk is a file named "Dingbats” that includes some graphic elements that comrespond to a comer
of a screen. To the right of the graphic of the moon is an omamental comer that corresponds to
the upper-right comer of the screen. Use the mouse Lo draw a rectangle around this graphic, and
click on"OK", Drag the graphic o the upper-right corner of the screen and click outside the
graphic to drop it in place.

Now, you want 1o make a copy of the graphic to place in another comer. You could use copy
& paste, but an easy way to do this is to use the Option key as you start to drag the graphic to
make a copy. Reselect the graphic by dragging a rectangle around the graphic, then hold down
the Option key as you drag the rectangle to the lower-right comer. Once you start dragging the
graphic, you can release the Option key. Holding down the Option key as you start a drag
makes a copy of the selected regica.

When the graphic is positioned in the lower-right corner, go to the Edit menu, and choose Flip
Vertical. Use the mouse (o reposition the graphic to the exact place you want it (if it needs




adjustment). This time, don't click outside the graphic, but rather, hold down the Option key as
you drag the graphic to the lower-left corner. Holding down the Option key will automatically
paste the graphic in its current position before making the copy. When you've moved the
graphic to the lower-left corner, go to the Edit menu and choose Flip Horizontal. If the graphic
is where you want it, hold down the Option key again as you start 10 drag the copy 10 the upper-
left comer. In the upper-left comer, choose Flip Vertical once more from the Edit menu, make
sure the graphic is placed where you want it, and click outside the rectangle to drop it in place.

In general, the Flip commands just reverse the image of whatever area is selected. This function
can also be used to reverse the direction of arrows, direction of cars, airplanes, etc. Note: fringe
graphic bits, when horizontally flipped, may expand slightly giving fuzzy edges in some cases.
This effect happens when a graphic has an edge of a different color, for example, grey pixels on
the edge of a different color image. Removing edge colors will make graphics easier to flip, but
we should mention that there's no reason to arbitrarily remove edge colors from all your
graphics. In normal use, edge colors give a better overall appearance 1o an image.

= Draw Multiple (Options menu), Check this item in the Options menu to creale interesting
patecms. When this option is checked, rectangles, ovals and the line tool will leave a repeating
paiiem as the mouse is moved.

» Draw Centered (Options menu). Check this item o draw a circle or square centered around
a specific point. If you combine Multiple and Centered, you can get very inieresting geometric
patierns,

+ Color Replace (Options menu). This is a very useful new addition to the HyperStdio

paint iools. It is used io change every pixel in a given selected area from one color 1o another. If
no area has been selecied, the entire screen will be processed. In the Replace dialog box, you
can also choose "Exchange”. This will swap the two colors in the selected area. This can be
used to create an "inverted” image, and may also be of use when importing graphics from other
paint programs with the proper colors in the palette, but in a different order than the usual
HyperStudio palette.

+ 320 Mode Alert Box. To help determine when a 320-mode graphic is being imported,
HyperStudio examines every graphic file before loading it; if it appears to be a 320-mode
graphic, a dialog box now appears, telling you that the graphic may change colors when loaded.
Note: Some 640 graphics, when saved in certain paint programs, do not include paletie
information, and as such will display the 320-mode alert message even though they will be
imported with normal colors. The alert message only tells you the graphic may be a 320 mode
graphic. Some graphic files from the original 1.0 and 1.2 versions of HyperSwudio may trigger
this alert window. To "fix" them, simply lnad a graphic as a Background on a blank card, and
then immediately re-save the screen back with the Save Screen option in the HyperSwudio File
menu (use the same name o save with).

« Colors menu. The Colors menu can now be used 1o set the color of text, in not only the
paint text tool, but in text items and button labels as well. Simply choosing a color from the
Colors menu is now equivalent to using Set Text Color (in the Options menu). The Colors
menu can also be used to set the Background color. Simply hold down the Option key while
choosing a color, and this will set the current Background color. If a button has been selected
with the button tool, then holding down the Option key will change the bution color. If a text
item has been selected, then the Option key will set the entire Background color for the text
item. While entering text in a text item, you can use the Colors menu to set the current text or
Background color as you go. Choosing a color while the eraser ool is active sets the
Background color without having to hold down the Option key.

« "Dropping” Invisible buttons, Animation and "Add a Graphic Item"

rectangles. When placing an invisible button, full-screen animation window, or a graphic
itern, you can press Return instead of clicking outside the reclangle to drop the item. This is
provided for those situations where the rectangle takes up the entire screen, and there is no
"outside the rectangle” to click in!

Button and Text Item Colors & Styles

+ As mentioned in the discussion of the Colors menu, previously, buttons and text items now
use the current text and background color settings. These colors can be changed using either the
Colors menu (with or without the Option key) while an item is selected, or by using the Set
Text Color... or Background Color... functions in the Options menu. Text items now also
support multiple text styles. Buttons are still limited to Shaston 8, although different colored

text is supporied.

New Button Actions

« Next/Previous card are now relative motions. That is, in HS 2.0, use of Next and
Previous established an absolute link to card #n. "Next card” buttons like right-arrows couldn't
be copied to other cards (i.e., the copied button would still branch 1o card #n.). HS 2.1 now
uses the action Next and Previous as "current card +/- 1", which means arrow buttons can be
copied and pasted as desired with the expected result

» Home card action: This is equivalent to the user pressing Apple-H, The advantage of this
is that in earlier versions of HyperStudio, a link to the Home.Stack with the Connect to
Another Stack action linked the bution with an absolute pathname for the Home.Stack. This
limits return Lo a specific stack with a specific pathname (if another Home.Stack is not
available in the same directory as the active stack). HyperStudio now "remembers” the location
of the last Home.Stack, no matter what directory it was in. This will be more flexible for hard
disk usage, and also allows the concept of multiple Home.Stacks on the same disk, hard disk,
or network. For example, you could have three different Home.Stacks, designed for different




kinds of users, that all launched the same application stacks. By using the new Home action
(rather than the old absoluie link), each stack will automatically return to the Home.Stack that
called ir

Improvements to Editing

« Pasic Card inserts card after current card (not at end of stack). Note: The "Card #" that is
displayed in the menu bar is a card identifier number, not a "position indicator”. Since the cards
are numbered beginning with "1" as your create a stack, this ID number is pretty much the
same as the position number, However, as you start to cut and paste cards from different
stacks, or within the same stack, you'll find the ID numbers follow the cards. That is, if you
cut a card from the end of the stack (say, card #9), and paste it near the front, you may notice
that the card #s then count 1,9,2,3, etc. This does not effect the operation of your stack. Cards
ﬁnmmﬂgmnbemdwtmncardﬁamcu[nrpﬂsmd,becauseﬂtbuuonmmﬁumamaﬂbasedm
card ID #.

Miscellaneous Improvements

+ Move to Card # (Move menu). Use this to move to any card # in the current stack. Just
enter the card ID # (which may be different than its position in the stack) in the Move To dialog
box.

= Save screen now saves complete image (buttons, text items, etc.) depending on
setting of "Hide Items" in Options menu.

= Cosmetic changes to Sound Record/Playback screen. The "tape recorder” screen
now has a numbered scale by the volume slider to make it easy to use consistent volume
settings for a group of sounds. (File note: the file HS.TD is now obsolete, and is no longer
used by the HyperStudio program.)

= "Stack Info" shows usable free memory. The Stack Info dialog box now indicates

how much memory is still available o the stack you are building. This number is smaller than
the amount of raw free memory in the computer because it is only the largest single block of
memory that is useable for a stack. Check this dialog box occasionally as you build your stack
to stay aware of how much remaining room for expansion you have.

= Version compatibility: All stacks created with previous (versions 1.2 and 2.0) of
HyperStudio can be used with 2.1. Depending on the number of buttons and text fields in the
stack, however, there may be a delay due to the conversion process. During the conversion, the
cursor will change to an alternating "2.0/2.1" marker. Once converied, you can save the stack
back to disk, and subsequent loads will be at normal speed since no conversion will be needed.
Stacks created or saved from HyperStudio 2.1 are not backward-compatible with earlier versions
of HyperStudio (however, since the 2.1 update is being sent to all HyperStudio users, this
should not be a problem, and there is no reason to maintain earlier-version copies of any of
your stacks). .

» Locked stack changes: When a stack is locked and the menu bar is hidden on a card,
HyperStudio will ignore the keyboard commands for Move to beginning and end of stack, and
next-card, previous-card. This lets you control the user’s actions a little better in test stacks,
adventure games, eic.

IMPORTANT: It is now possible to create a stack which cannot be unlocked! 1f you

hide the menu bar on all cards but the last card, and then lock the stack and save it, AND there
is no button that specifically moved to that last card, you will not be able 1o get back to the
last card to ever unlock the stack again (or make changes). This is a "feature” for those wanting
1o create absolutely locked stacks, but you should use this option with care, and always keep
another unlocked copy of the stack as a backup.

= Usage tip: A stack can be locked wirthow using a password. All that is necessary is 10
check the box "Locked Stack” in the Preferences dialog box. A password need not be entered to
lock a stack. This will make it easier for other users of your stacks to unlock them to make
changes in those cases where this is not an issue for them. We've seen a number of stacks in
the public domain that are locked with a password where there is really no need to use one. You
should use password-locked stacks only in those cases where you absolutely do not want any
user to alter your stack. This might be the case for test stacks used by students, but we
encourage you to use this feature sparingly.

» Apple-S now is the keyboard equivalent for SAVE. It used to be for Save As...
'I'hiswi]]letyousavestacksinmndywimasinglekeypress.lfmesmk'nsbmndmwmﬂhm
not yet been given a name, pressing Apple-S will bring up the Save As dialog so you can name
the file,

« Show Invisible Buttons. Holding down the Apple- and Option-keys simultaneously will
display the invisible buttons on a screen. This is disabled if a stack is locked.

» "Local" directory application support. Siacks moved to new directories can launch
applications in the same directory with no button editing. HyperStudio 2.0 linked buttons to
applications with an absolute pathname, and, for example, moving Sound Shop to a hard disk
lost the connection 1o that program in the Home.Stack. In HyperStudio 2.1, buttons will find
applications at both their original location and the local directory, if present

« Modified PRODOS file. This is a special version of PRODOS (on the /HyperStudio

disk) that gives a little more usable memory on a ROM 03 Apple [IGS. It has no effect on a
ROM 01 machine. Move this file to your startup volume if you aren't using the /HyperStudio
disk.




* CLV (time-based or "Extended Play") laser disc support. This version of

HyperStudio now supports CLV laser discs. Note: The software interface for CLV discs is a
little more sensitive than the frame-based drivers, and may require that you use the START
button in the remote-control dialog box that comes up when you choose "Add a Video" (Objects
menu) or "Play a Video" (button action). The START button only needs to be used when you
first insert a new laser disc. The way to tell that everything is properly started and synchronized
18 o make sure that the little button 1o the right of the frame # indicator reads "Tm" (for
"Time"), rather than "Ch", "Fr", or a blank button.

The number register for CLV disks is in HR-MIN-SEC format. That is, a number valve of
02030 would mean O hours, 20 minutes, and 30 seconds. Since there can only be one hour of
video on a side of a laser dise, the first digit will always be "0". Entering a number like 00090
will ﬂm::v a corrected value of 000130 (that is, 90 seconds is converted to 1 minute, 30

Creating User Disks for Others

Although the HyperStudio program itself cannot be given o others, a way has been provided to
creale disks with your stacks that are independent of the original HyperStudio program. This is
done using an additional file, HS.Sys16, that is located on the HS.Art disk.

HS.Sys16 is a miniature version of HyperSmdio that has no editing functions, only the ability
to run stacks you've created. Disks for other Apple IIGS users are created by puiting this file
on a disk, along with your own stacks. The "User Disk"” you create this way can either be a
startable disk, and thus completely self-contained, or you can create disks with just the
HS.Sys16 file and your stacks. In this lauer case, the user would have to start up the computer
with a System Disk, or other startable disk, and then launch HS.Sysl6 from the Finder, or
other program launcher.

Remember, since any stack can branch to another stack, even on another diskette, it is not
necessary that all the stacks for your project fit on one disk. You could, for example, create a 2-
disk set with a startable disk with HS.Sys16 and your Home Stack on the first disk, and then

use a button (o link (o the stacks on the second disk. This is the way the /HyperStudio and
/HS.Demo disks are set up in the HyperStudio package,

File-Copy Instructions

The following instructions are for those familiar with copying files between disks. If you are
more comfortable with an automated process, skip ahead to the section titled "Installer
Instractions”. That section describes a utility that will automatically create User Disks for you.

» Startable User Disks: To create a disk with System files that will start up to your own
Home Stack, do the following:

1. Creaie a startable System disk with the file PRODOS and the System folder. You should
delete, if necessary, the files START and P8 from the System folder, along with any

Driver files (System/Drivers). You should also delete BASIC.System and
BASIC Launcher, if necessary, from the main directory.

2. Copy the file HS.Sys16 from the HS.Art disk to your new disk.
3. Copy your own Home.Stack 1o your new disk.
That's it! This will now give you a self-contained disk, that when started up, will go directly 10

your own Home.Stack. This disk can be distributed to others in accordance with the HS.Sys16
License Agreement.




* Non-Startable User Disks: If you do not require a startable disk, you need put only the
file HS.Sys16 on your disk, along with whatever stacks you wish.

IMPORTANT!! YOU MAY NOT, UNDER ANY
CIRCUMSTANCES, DISTRIBUTE COPIES OF THE
HYPERSTUDIO FILE. ONLY THE HS.SYS16 FILE MAY BE
LEGALLY COPIED UNDER THE PROVISIONS OF THE
HS.SYS16 DISTRIBUTION LICENSE.

In general, if you will be selling the disk with your stacks, this is considered "commercial use”
of the HS.5ys16 nn-time file, and a modest annual license fee must be paid to Roger Wagner
Publishing, Inc. If you are not selling your stacks, then no license fee is required. Non-
commercial use would include public domain stacks in user group libraries, stacks shared with
friends and family, and stacks created for non-commercial distribution in schools.

Installer Instructions

This section describes how to use the Installer utility, provided on the /HyperStudio disk. This
utility will amtomatically copy all the necessary files to create a User Disk for your own stacks.

You will also need the /System.Disk for GSOS version 5.0.2 or later, as
supplied with your Apple IIGS computer, and/or by your local dealer.

1. Start up your computer with the /System.Disk. This will eventually display the Finder.

2. Insert a blank disk. When prompted, format the disk as you would any data disk, and name
the disk User.Disk (or any other name you wish).

2a. If you have a disk that is already formatted that you are "recycling”, choose Erase Disk
from the Disk menu of the Finder after selecting the disk to be erased.

3. Insert the /HyperStudio disk, and launch the Installer program.

4, Click on the Disk button until you see your disk (User.Disk or 77?) identified at the top of
the window on the right of the screen.

5. Scroll down through the list on the left until you see the entry "Latest Sys. Files (No
Finder)". Select this by clicking with the mouse on the entry.

6. Click on the Install button at the top-center of the screen. As the installation process
proceeds, you will be prompted, if necessary, to insert the appropriate disks.

7. Again, use the Disk button to select your disk (User.Disk), and choose "User's Startable HS
Disk” as the Update Selection.

8. Click on the Install bution to begin the process. When finished, choose Quit to retumn to
the Finder.

You now have a disk that, when started up, will display a title screen, and go to a "dommy”
Home Stack. You may want to keep a backup copy of this disk to use as a siarting point for
other User Disks in the future.

Customizing the Disk

» Home Stack: The first thing you'll want to do is to replace the Home.Stack on the
User.Disk with your own Home.Stack. This can be done by running your own full-version of
HyperStdio, loading your Home.Stack, and then saving it to the User Disk. Other stacks may
be added as room allows. Depending on how many stacks are in your project, it may be
necessary 10 create a second disk, perhaps called User.Disk2, that contains just the additional
stacks that won't fit on the first disk. It is not necessary o put the System files or HS.Sysl6
on any other disk other than your first startup disk (User.Disk).

+ Startup Screen: The HyperStudio disk has a startup screen that is shown every time the
disk is started up. You can create the same effect on your own disks by using the Sight 'n
Sound utility (there's an icon for this the HyperStudio Home Card under "Applications”) to add
your own startup picture. On the HS.Art disk is a file named "User.Title.Scm” that you can use
as a starting point for your own startup screen, and customize this graphic for your own disk.

You can also add a startup sound to your User Disk using the Sight 'n Sound utility. Be aware
that a startable disk with System files doesn't have a lot of extra space on ii, and it may not be
possible to fit the System files, a large Home Stack, and a large sound file on the disk. This
may take a little experimenting to balance the use of the available space on a given disk to your
satisfaction.
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